Написать программу в паскале. ввести n чисел. найти первое максимальное число и его номер.

NoProblem75 NoProblem75    3   02.10.2019 04:10    0

Ответы
Знания Знания  17.08.2020 06:46
PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ReadArrReal('Вводите:', ReadInteger('Количество чисел?'));

 var imax := a.IndexMax;

 Writeln('Первое максимальное число ', a[imax],

     ' имеет номер ', imax + 1)

end.

ПримерКоличество чисел? 5Вводите: 14 2.17 15.2 8 15.2Первое максимальное число 15.2 имеет номер 3
ПОКАЗАТЬ ОТВЕТЫ
orehovas orehovas  17.08.2020 06:46

var n,i,m,k,a: integer;

begin

write ('Введите количество чисел: ');

readln (n);

write ('Введите число: ');

readln (a);

m:=a;

k:=1;

for i:=2 to n do

begin

write ('Введите число: ');

readln (a);

if a>m then

begin

m:=a;

k:=i

end

end;

writeln ('Первый максимальный элемент ',m,' и его номер ',k)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика