Написать программу в паскале, в которой нужно ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом.

Dima1208 Dima1208    3   18.09.2019 19:40    3

Ответы
markelovakristi markelovakristi  08.10.2020 00:40
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите натуральное число');
  var r:=n.ToString.Pairwise.Where(t->t[0]=t[1]).Any;
  if r then Writeln('Есть две одинаковые цифры, стоящие рядом')
  else  Writeln('Нет двух одинаковых цифр, стоящие рядом')
end.

Пример
Введите натуральное число 245005
Есть две одинаковые цифры, стоящие рядом
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика