Написать программу в паскале. указания: заполните одномерный числовой массив а[15] случайными целыми числами в интервале [18; 15].выведите значения элементов массива сначала в столбик,а затем в строку,причем на каждый элемент отведите 4 позиции. : заменить элементы массива,которые кратны пяти,на значение максимального элемента массива.

Raterford Raterford    3   09.06.2019 07:10    1

Ответы
MackTraher MackTraher  01.10.2020 22:53
Const n=15;
var
a:array[1..n]of integer;
i,i_max:integer;
begin     
    for i:=1 to n do       
      begin             
          a[i]:=random(4)+15;           
          writeln(a[i]);         
      end;     
writeln;   
     for i:=1 to n do         
         write(a[i]:4);         
              writeln;     
     i_max:=1;     
         for i:=2 to n do         
           if a[i]>a[i_max]then           
              i_max:=i;     
         for i:=1 to n do       
             if a[i]mod 5=0 then           
                 a[i]:=a[i_max];     
        for i:=1 to n do       
           write(a[i]:4);
            end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика