Написать программу в паскале, тема массивы возвести в квадрат элементы, не превосходящие по модулю введенное с клавиатуры число r.

alyakozlova22 alyakozlova22    2   04.10.2019 13:40    4

Ответы
Кристина1902 Кристина1902  09.10.2020 19:42

const n=10;

var a:array[1..n] of integer;

i,r: integer;

begin

write (' Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(41)-20;

write (a[i]:3,' ')

end;

writeln;

write ('Введите число: ');

readln (r);

write ('Преобразованый массив: ');

for i:=1 to n do

begin

if abs(a[i]) <= r then a[i]:=a[i]*a[i];

write (a[i]:3,' ')

end

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика