Написать программу в паскале составить программу которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный массив

адрдрюе адрдрюе    3   25.05.2019 10:20    5

Ответы
новичок604 новичок604  21.06.2020 12:06
Var a: array [0..10, 0..50] of integer;
    b: array [0..10] of integer;
    i, j: integer;
begin
     for i := 0 to 10 do
     begin
         for j := 0 to 50 do
         begin
              a[i, j] := random(50);
              write(a[i, j]:3);
         end;
         writeln();
     end;
                       for i := 0 to 10 do
         for j := 0 to 50 do
             b[i] := b[i] + a[i, j];
                  for i := 0 to 10 do
             write(b[i], ' ');
end.

Можно было, конечно, поменьше циклов, но так нагляднее будет =)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика