Написать программу в паскале позволяющую найти среднее арифметическое элементов массива состоящего из 10 чисел которые превышают число c.

ArturGafiyatullin145 ArturGafiyatullin145    3   14.09.2019 21:40    7

Ответы
Gafana Gafana  26.08.2020 20:52
1.
begin
 var a:=ArrRandom(10,1,50); a.Println;
 var c:=ReadInteger('c = ');
 var s:=a.Where(x->x>c);
 if s.Count>0 then
 writeln('Среднее арифметическое элементов > ',c,' = ',s.Average)
 else writeln('В массиве нет искомых элементов');
end.

Пример:
8 2 22 16 24 34 29 16 1 26
c =  50
В массиве нет искомых элементов

2.
const n=10;
var a:array[1..n] of integer;
c,i,s,k:integer;
begin
Randomize;
for i:=1 to n do begin
 a[i]:=random(51);
 write(a[i],' ');
 end;
writeln;
write('c = ');
readln(c);
s:=0; k:=0;
for i:=1 to n do
 if a[i]>c then begin s:=s+a[i]; k:=k+1; end;
if k>0 then writeln('Среднее арифметическое элементов > ',c,' = ',s/k:5:2)
else writeln('В массиве нет искомых элементов');
end.

Пример:
39 38 43 25 45 16 16 12 35 16
c = 40
Среднее арифметическое элементов > 40 = 44.00
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика