Написать программу в паскале: получить в убывающем порядке все двузначные числа, в десятичной записи которых нет цифры 5.

marinadobrynin1 marinadobrynin1    2   29.07.2019 10:40    9

Ответы
timaAlexandrow timaAlexandrow  27.09.2020 11:29
Var
    i: integer;

begin
    for i := 99 downto 10 do
        if (i mod 10 <> 5) and (i div 10 <> 5) then
            write(i, ' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
ivanovaizl ivanovaizl  27.09.2020 11:29
Program dig_2_no5_downto;

var
   i,a,b: integer;

begin
  i := 99;
  while i >= 10 do
    begin
      a := i div 10;
      b := i mod 10;
      if (a <> 5) and (b <> 5) then
        write(i, ' ');
      i := i - 1;
    end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика