Написать программу (в паскале) поиска элемента массива, равного 50

Metalmekid Metalmekid    2   18.09.2019 17:30    10

Ответы
bakhtovar2 bakhtovar2  08.10.2020 00:28
Const n=20; p=50;
var a:array[1..n+1] of integer;
i:integer;
begin
randomize;
for i:=1 to n do
 begin
 a[i]:=random(100);
 write(a[i]:4);
 end;
writeln;
a[n+1]:=p;
i:=1;
while a[i]<>p do i:=i+1;
if i<n+1 then writeln('Значение = ',p,' - это ',i,' элемент массива')
else writeln('Значения ',p,' в массиве нет');
end.

Пример:
76 27 15 97 12 14 72 50 51 8 40 47 38 28 30 47 31 4 94 3
Значение = 50 - это 8 элемент массива
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика