Написать программу в паскале по вычислению средний температуры за неделю.исходные данные вводятся с клавиатуры: понедельник 12 градусов вторник 10 среда 16 четверг 18 пятница 17 суббота 16 воскресенье 14

Марина19r Марина19r    2   18.03.2019 07:30    3

Ответы
Ксюша10092007 Ксюша10092007  25.05.2020 22:41

var

  t: array [1..7] of real;  //Массив температуры за неделю

  s: real;

  i: integer;

 

begin

  s:= 0;

  for i:= 1 to 7 do  //Вводим температуру за каждый день

  begin

    writeln('Введите температура в ', i, ' день недели');

    readln(t[i]);

    s:= s + t[i];

  end;

  writeln('Средняя температуры за неделю:  ', s / 7 : 0 : 5);  {Выводим среднюю температуру за неделю с округлением до 5 знаков после запятой}

end.

  

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика