Написать программу в паскале. найти все трехзначные числа, которые можно представить разностью между квадратом числа, образованного первыми двумя цифрами и квадратом третьей цифры. нужно!

kumalena73 kumalena73    3   11.07.2019 06:50    14

Ответы
oksana2000001 oksana2000001  03.10.2020 01:05
Вот программа:
var n,i:integer;
begin
for i:=100 to 999 do
 if i=(i div 10)*(i div 10)-(i mod 10)*(i mod 10) then writeln(i);
end.
А чисел таких оказалось всего 2:
100
147
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика