Написать программу в паскале, массив который меняет 5 и 3 строку.

Olga831106 Olga831106    1   26.07.2019 14:50    0

Ответы
xxlllxxx xxlllxxx  03.10.2020 13:34
Const n=6; m=4;
var 
a:array[1..n,1..m] of integer;
i,j,c:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
  a[i,j]:=random(50);
  write(a[i,j]:4);
  end;
  writeln;
 end;
for j:=1 to m do
 begin
 c:=a[3,j]; a[3,j]:=a[5,j]; a[5,j]:=c;
 end;
writeln('Полученный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do write(a[i,j]:4);
 writeln;
 end;
end.

Пример:
Исходный массив:
  25   4  33  17
  19  23  42   9
  36  40   1  48
  21  44  13  18
  38  29   8   7
  24  13   5  13
Полученный массив:
  25   4  33  17
  19  23  42   9
  38  29   8   7
  21  44  13  18
  36  40   1  48
  24  13   5  13
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика