Написать программу в паскале массив 5х3 заполнить случайными числами [0; 100]. в каждой строке поменять местами максимальное и минимальное число.

Kulimshina Kulimshina    2   06.10.2019 04:40    5

Ответы
egorpolozuk egorpolozuk  09.10.2020 23:00

const g = 5; v = 3;

var a: array[1..g,1..v] of integer;

i,j,maxj,minj,p:integer;

begin

writeln('Массив: ');

for i:=1 to g do

begin

for j:=1 to v do

begin

a[i,j]:=Random(101);

write(a[i,j]:4)

end;

writeln

end;

for i:=1 to g do

begin

maxj:=1;

minj:=1;

for j:=1 to v do

begin

if a[i,j]>a[i,maxj] then maxj:=j;

if a[i,j]<a[i,minj]then minj:=j;

end;

p:=a[i,maxj];

a[i,maxj]:=a[i,minj];

a[i,minj]:=p;

end;

writeln;

writeln('Преобразованный массив: ');

for i:=1 to g do

begin

for j:=1 to v do write(a[i,j]:4);

writeln

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика