Написать программу в паскале котрая расставляет три числа в порядке возрастания

p5wf389f p5wf389f    2   01.03.2019 07:10    4

Ответы
masha2820 masha2820  23.05.2020 17:57

program ttt;
var i,j,a,b,c:integer;
begin
readln(a);
readln(b);
readln(c);

if (a>b) then
if (a>c) then
begin
write(a);
if (b>c) then begin write(b);write(c) end; else begin write(c); write(b);end
end; else

if (b>c) then begin write (b); if(a>c)then begin write(a); write(c);end; else begin write(c); write(a);end; end;
else begin write(c); if(a>b) then begin write(a);write(b)end; else begin write(b); write(a); end;end;

end;

неоптимальный, но понятный алгоритм.
а в другом случае можноо оптимизировать.. как- подумай -;)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика