Написать программу в паскале , которая вычесляет y=2x+3x2+4x3++10x11

Kuzenka2003 Kuzenka2003    1   24.04.2019 11:42    1

Ответы
nsmorizevs nsmorizevs  08.06.2020 16:45

Объяснение:

Смущает последнее слагаемое, выбивается из закономерности.

должно быть 11х¹⁰ или 10х⁹

program sumxproj;

uses math;

var

x,Y:real;

n,i:integer;

begin

Write('Введите x=');

readln(x);

n:=10;

Y:=0;

for i:=1 to n do

Y:=Y+(i+1)*power(x,i);

writeln('Y=',Y:6:2);

readln;

end.          

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика