Написать программу в паскале которая сначала должна обеспечить ввод 5 чисел в одномерный массив затем вычислить количество четных и вывести сумму четных на экран a[1]=6 a[2]=5 a[3] a[4]=3 a[5]=2 количество четных чисел =3 cумма четных чисел=12.

babykitten5002p08hdk babykitten5002p08hdk    2   02.10.2019 07:50    3

Ответы
rusrusik rusrusik  09.10.2020 11:18

//PascalABC.NET v3.3 1633


var arr: array [1..5] of integer;

begin

 for var i:=1 to 5 do

   arr[i]:=readinteger('Введите '+i+' элемент массива: ');

 

 var sum:=0;

 var number:=0;

 for var i:=1 to 5 do

   if arr[i] mod 2 = 0 then

   begin

     sum += arr[i];

     number += 1;

   end;

 

 writeln('Количество четных чисел = '+number);

 writeln('Сумма четных чисел = '+sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика