Написать программу в паскале, которая формирует матрицу nXn в следующем виде: У меня есть программа, которая формирует матрицу в виде:
1 1 1 1 1 1 1 1 1 1
2 2 2 2 2 2 2 2 2 1
3 3 3 3 3 3 3 3 2 1
4 4 4 4 4 4 4 3 2 1
5 5 5 5 5 5 4 3 2 1
6 6 6 6 6 5 4 3 2 1
7 7 7 7 6 5 4 3 2 1
8 8 8 7 6 5 4 3 2 1
9 9 8 7 6 5 4 3 2 1
10 9 8 7 6 5 4 3 2 1
И программа для нее:
var
n,i,j: integer;
a: array[1..20,1..20] of integer;
begin
write('Введите размерность матрицы');
readln(n);
for i:=1 to n do
begin
for j:=1 to n do
begin
if i+j a[i,j]:=n-j+1;
write(a[i,j]:4);
end;
writeln;
end;
end.


Написать программу в паскале, которая формирует матрицу nXn в следующем виде: У меня есть программа,

gushagusha gushagusha    2   04.11.2020 13:50    12

Ответы
bogussasa7 bogussasa7  04.11.2020 14:00

1

1

1

1

1

2

3

4

5

6

End end endend

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика