tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу в
Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел
клэш4
1 15.06.2019 14:50
1
Ответы
Макс111111м
12.07.2020 18:16
Var a,n,sum: integer;
begin
sum:=0;
n:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
n:=n+1;
end;
writeln(sum/n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Kymir1
11.05.2020 20:02
Определи, может ли существовать такой IP-адрес: 104.173.205.280 (рядом напишите причину вашего решения) 1. может существовать, (почему?) 2. не может существовать, (почему?)...
romatrapkin9091
11.05.2020 20:03
Определите значение сигнала на выходе логической схемы, Мой ответ...
kotflin
11.05.2020 20:03
Задача 2. Вычислить значение заданной функции2х - 12, если -3 x 5,7 – 8х, для всех других х.Фрагмент проекта для решения этой задачи будет выглядеть так::- StrToFloat(Edit1.Text):If...
mozhena2000
11.05.2020 20:03
С++, написать программу Рассчитать интегралы двумя методом прямоугольников и метод трапеций). Написать программу для расчета определенного дифференциала....
Lyashchyov4777
11.05.2020 20:04
Определите значение сигнала на выходе логической схемы Мой ответ Укажите отрицания высказывания «Для каждого из нас учить второй...
Милки1319
11.05.2020 20:04
1. Сколько позиций в строке используется для записи операторов (исходных данных)?2. Как записываются числовые значения данных в строке?...
анна2216
03.08.2019 11:20
Какой тип имеет переменная h, если после выполнения оператора write (h) на экран было выведено следующее: 1399? boolean integer shortint нет верного ответа...
anyiugyo9e7
03.08.2019 11:20
Статья содержит 45 страниц , на каждой из которых 30 строк, а в каждой строке 60 символов...
virki2018
03.08.2019 11:20
Оля лена и валя замечательные девочки и каждая из них играет на каком-нибудь музыкальном инструменте и говорить на одном из иностранных языков. инструменты языки у них разные....
kristinakomaro5
03.08.2019 11:20
Записать следующие числа в порядке возрастания: 11000111(2),154(10),226(8),f1(16)...
Популярные вопросы
У якому рядку всі метали вступають в реакцію зміщення з кислотами а) К, Pb,...
3
Запиши какие государственные во решал шаньюй...
3
от ❣❣❣❣❣❣❣❣❣и кроме задания,решите правильно...
3
Як ви розумiете висли Елiсенди « пекло, повне ангелiв»...
3
Найдите наименьшее и наибольшее значение функции y=sin(x-п/4)+0,5 на промежутке...
2
Подані числівники поставити у формі родового, давального й орудного відмінків....
2
Побудувати графік функції y=3-|x|...
3
решить подставления и сложения 2x=2+y,2x+y=8...
2
Буктрейлер до книги Чарівна крамниця...
3
МОМОГИТЕ БАЛОВ В приведённых примерах выбери только те, в которых один объект...
1
begin
sum:=0;
n:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
n:=n+1;
end;
writeln(sum/n);
end.