Написать программу в паскале из диапазона от 10 до 1000 компьютер выбрал случайным образом число. если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число,
выбранное пк и новое, полученное после перестановки цифр. в противном случае, вывести выбранное пк число

DikaTheBro DikaTheBro    1   09.03.2019 04:50    4

Ответы
chapa00 chapa00  24.05.2020 09:29

var x,x1,x2,x3: integer; //x1- 1 число, х2- 2 число, х3 - 3 число

begin

  randomize;

  x:=random(1000)+10;

  if x div 100 >0 then begin x1:=x div 100;

                                         x2:=(x mod 100) div 10;

                                         x3:=(x mod 100) mod 10;

                                         writeln(x,', ',x3,x2,x1);

                                 end

                         else writeln(x);

end.

     

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика