Написать программу в паскале: даны целое n> 0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. найти величину наибольшего среди отрицательных чисел этой последовательности.

marrycat1 marrycat1    2   04.06.2019 15:10    8

Ответы
Александа7 Александа7  05.07.2020 14:15
Var
  x,max:real;
  n,i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
  begin
  write('Введите число ',i,': ');
  readln(x);
  if x<0 then
     begin
     if max=0 then max:=x;                     // если это первое отр.число
     if x>max then max:=x
     end
  end;
writeln('Наибольшее среди отрицательных: ',max)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика