Написать программу в паскале. дано натуральное семизначное число р. вывести на экран цифры чила, которые делятся на а без остатка. определить кол-во цифр, удовлетворяющих этому условию.

an02092004 an02092004    1   02.09.2019 21:30    2

Ответы
мария2386 мария2386  01.09.2020 06:57
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Write('Введите Р и а: ');
  var (P,a):=ReadInteger2;
  var k:=0;
  while P>0 do begin
    var d:=P mod 10;
    if d mod a=0 then begin Print(d); k+=1 end;
    P:=P div 10
    end;
  Writeln(Newline,'Искомых чисел: ',k)
end.

Пример
Введите Р и а: 7568450 5
0 5 5
Искомых чисел: 3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика