Написать программу в паскале. дано число n. найти сумму его делителей.

Zhamik11 Zhamik11    3   24.07.2019 23:40    1

Ответы
Alekskarpov Alekskarpov  03.10.2020 12:09
Var n,s,i:integer;
begin
write('N = '); readln(n);
if n>1 then s:=1+n else s:=1;
for i:=2 to n div 2 do
 if n mod i = 0 then s:=s+i;
writeln('S = ',s);
end.

Пример:
N = 12
S = 28
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика