Написать программу в паскале. дан массив размера n. массив отсортировать в порядке возрастания. для отладки программы числа последовательностей сформировать с генератора случайных чисел.

katetolstoshev2 katetolstoshev2    2   29.08.2019 22:20    2

Ответы
Виктория41116 Виктория41116  06.10.2020 03:51
Uses Crt;
Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,j,Min,B:integer;
Begin
ClrScr;
Randomize;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(2*N+1)-N;
    Write(' ',A[i])
    End;
WriteLn;
Write('Отсортированный массив:');
For i:= 1 to N do
    Begin
    Min:=i;
    For j:= i+1 to N do
        if A[j] < A[Min] then Min:=j;
    B:=A[i];
    A[i]:=A[Min];
    A[Min]:=B;
    Write(' ',A[i])
    End;
ReadLn
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика