Написать программу в паскале abc. вывести на экран все двузначные числа, сумма цифр которых равна заданному числу n

danilpetuhuv03 danilpetuhuv03    1   29.06.2019 16:30    3

Ответы
MaveJ MaveJ  02.10.2020 15:19
Блин! Начал писать программу, а комп ВЫЛЕТЕЛ
Поэтому припоздал

uses Crt;
var i, n, m, z1, z2 :integer;

begin
 ClrScr;
 Write (' n = ');
 ReadLn(n);
 WriteLn;
 if (n<0) or (n>18) then WriteLn (' None!')
 else begin
      for i:=11 to 99 do
         begin
           m:=i;
           z1:=m div 10;
           z2:=m mod 10;
           if (z1+z2=n) then Writeln(' m = ', m);
         end;
      end;
 ReadLn;
end.
ПОКАЗАТЬ ОТВЕТЫ
krictina1959 krictina1959  02.10.2020 15:19
Var
i,j,n:integer;
begin
read(n);
for i:=1 to 9 do
for j:=0 to 9 do
if i+j=n then
Writeln(i,j , ' = ', n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика