Написать программу в паскаль ввести текст состоящий из слов , разделённых между собой запятыми. сколько раз в тексте встречается слова "мама" в найденных словах изменить букву "м" на букву "п" так же нужно прописать программу простую и понятную по синтаксису
begin
var s := ReadlnString('>');
var r := new Regex('\bМама\b');
Writeln('Количество слов "Мама": ', r.Matches(s).Count);
s := r.Replace(s, 'Пама');
s.Println;
end.
все просто и понятно)
только экранирующие символы пришлось поискать для слова целиком
Пример работы программы:
> Мама,Мамам,Мама,мама,Мама
Количество слов "Мама": 3
Пама,Мамам,Пама,мама,Пама