Написать программу в паскаль турбо

дан массив a размерностью n (размерность вводит пользователь). массив заполнен случайными числами от -15 до 15. каждый второй элемент заменить на результат их деления на предыдущий элемент (округлить до 2 знаков после запятой).

Мария31011 Мария31011    3   14.11.2019 10:04    1

Ответы
knestor knestor  10.10.2020 13:10

program gam;

const

 nn = 100;

var

 a: array[1..nn] of real;

 i, n: integer;

 r: real;

begin

 read(n);

 randomize;

 for i := 1 to n do

 begin

   a[i] := (random(3001) - 1500) / 100;

   write(a[i]:7:2);

 end;

 writeln;

 i := 2;

 while i <= n do

 begin

   a[i] := a[i - 1] / a[i];

   i := i + 2

 end;

 for i := 1 to n do

   write(a[i]:7:2);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика