Написать программу в паскаль. сформировать массив, подметить кол-во отрицательных элементов и заменить их на 2

pervushina245 pervushina245    1   30.08.2019 04:20    1

Ответы
megagda04 megagda04  06.10.2020 04:22
Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,k:integer;
Begin
Randomize;
k:=0;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(' ',A[i]);
    if A[i] < 0 then
       Begin
       k:=k+1;
       A[i]:=2
       End;
    End;
WriteLn;
WriteLn('Количество отрицательных элементов: ',k);
Write('Новый массив:');
For i:= 1 to N do
    Write(' ',A[i])
End.

Пример работы программы:

Исходный массив: -1 -9 7 -2 -5 -3 -1 6 3 -6 9 8 -10
Количество отрицательных элементов: 8
Новый массив: 2 2 7 2 2 2 2 6 3 2 9 8 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика