Написать программу в паскаль. дан массив целых чисел, состоящий из 20 элементов. заполнить его датчиком случайных чисел. заменить максимальный элемент на противоположный по знаку.

Юлька6488262 Юлька6488262    2   04.06.2019 10:50    4

Ответы
OSTROVSKAYA100 OSTROVSKAYA100  05.07.2020 12:25
Program chik;
const n=20;
var a:array[1..20]of integer;
i,l,max:integer;
begin
randomize;
for i:=1 to n do
a[i]:=random(100)-50;
max:=a[1];
for i:=2 to n do
if(a[i]>max)then max:=a[i];
for i:=1 to n do
begin
if(a[i]=max)then a[i]:=-max;
write(a[i],' ');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика