Написать программу в паскаль
Дан целочисленный массив размера NN, содержащий ровно два одинаковых элемента. Найти номера одинаковых элементов и вывести эти номера в порядке возрастания.

lololka125 lololka125    1   23.03.2020 06:26    6

Ответы
akhmetova1 akhmetova1  03.09.2020 17:27

Variant 1

var

 A: array[1..100] of integer;

 N, i, j: byte;

begin

 write('N = ');

 readln(N);

 for i := 1 to N do

 begin

   write('a[', i, '] = ');

   read(a[i])

 end;

 writeln;

 for i := 2 to N do

   for j := 1 to i - 1 do

     if a[i] = a[j] then begin

       writeln('Номера: ', j, ' и ', i);

       exit

     end;

 writeln

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика