Написать программу в паскаль абс по теме функции. : найти сумму цифр трех чисел.

Zan22 Zan22    1   26.07.2019 23:00    9

Ответы
ВАНЯПУХОВ ВАНЯПУХОВ  31.07.2020 19:53
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
function SoD(n:int64):integer;
begin
  Result:=0;
  while n>0 do begin
    Result+=n mod 10;
    n:=n div 10
    end
end;
    
begin
  var a:=ReadArrInteger('Введите три натуральных числа:',3);
  Write('Суммы цифр чисел: '); a.Select(x->SoD(x)).Println;
  Writeln('Общая сумма цифр всех чисел: ',a.Select(x->SoD(x)).Sum)
end.

Тестовое решение:
Введите три натуральных числа: 56325 23131 784545223
Суммы цифр чисел: 21 10 40
Общая сумма цифр всех чисел: 71
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика