Написать программу в PascalABC.net:

У трёх 6-значных чисел найти:

- произведение нечётных цифр

ClarisVerbis ClarisVerbis    2   31.03.2021 22:15    1

Ответы
castlecrashers castlecrashers  30.04.2021 22:16

var

pr1,pr2,pr3,a,b,c : integer;

begin

readln(a,b,c);

a := abs(a);

b := abs(b);

c := abs(c);

pr1 := 1;

pr2 := 1;

pr3 := 1;

while (a > 0) and (b > 0) and (c > 0) do

begin

if (a mod 10)mod 2 <> 0 then

pr1 := pr1 * (a mod 10);

a := a div 10;

if (b mod 10)mod 2 <> 0 then

pr2 := pr2 * (b mod 10);

b := b div 10;

if (c mod 10)mod 2 <> 0 then

pr3 := pr3 * (c mod 10);

c := c div 10;

end;

writeln(pr1,' ', pr2,' ',pr3);

end.

ПОКАЗАТЬ ОТВЕТЫ
SaLmOn4663 SaLmOn4663  30.04.2021 22:16

## uses School;

var P: integer -> integer := x -> x.Digits.Where(d -> d.IsOdd).Product;

ReadArrInteger(3).Select(n -> P(n)).Print


Написать программу в PascalABC.net:У трёх 6-значных чисел найти:- произведение нечётных цифр
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика