Написать программу в pascalabc.net : с клавиатуры вводятся 3 числа.найти среднее арифметическое двух больших и двух меньших.

lerafrank26022 lerafrank26022    1   12.03.2019 01:00    3

Ответы
MGap58 MGap58  24.05.2020 23:11

по нубски правдо очень проверить не забудь)

var
a,n,c:integer;
x,y:real;
begin
readln(a);
readln(n);
readln(c);
if ((a > n) and (n > c)) then begin
x:=(a+n)/2;
y:=(n+c)/2;
end else if((n > a) and (a > c)) then begin
x:=(a+n)/2;
y:=(a+c)/2;
end else if((c > a) and (a > n)) then begin
x:=(a+c)/2;
y:=(a+n)/2;
end else if((c > n) and (n > c)) then begin
x:=(c+n)/2;
y:=(n+c)/2;
end else if((n > c) and (c > a)) then begin
x:=(c+n)/2;
y:=(a+c)/2;
end else if((a > c) and (c > n)) then begin
x:=(c+a)/2;
y:=(n+c)/2;
end else if((c > n) and (n > a)) then begin
x:=(c+n)/2;
y:=(n+a)/2;
end;
write('наибольшее: ',x,' наименьшее: ',y);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика