Написать программу в Pascal: Найти сумму квадратов всех целых чисел от а до b (значение а и b вводятся с клавиатуры, b больше а).​

zhdiana0706 zhdiana0706    1   20.09.2020 00:30    4

Ответы
Мурмурыч Мурмурыч  20.09.2020 01:01

program skab;

uses

crt;

var

i, a, b, s: integer;

begin

s := 0;

writeln('Введите a, затем b (a<b) :');

readln(a, b);

if a < b then

begin

for i := a to b do

s := s + (i * i);

writeln('Сумма квадратов целых чисел от а до b: ', s);

end

else

writeln('Ошибка! Проверьте правильность введённых данных! Закрытие программы...');

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика