Написать программу в pascal начисления скидок: если сумма покупки > 100, то скидка 10%. если меньше или равна 100, то скидка 5%

LoveSmile78900987 LoveSmile78900987    2   25.08.2019 18:10    1

Ответы
ksyushay02 ksyushay02  05.10.2020 19:18
Var s:real;
begin
write('Сумма покупки = ');
readln(s);
if s>100 then writeln('Скидка = ',s*0.1)
else writeln('Скидка = ',s*0.05);
end.

Пример:
Сумма покупки = 200
Скидка = 20
ПОКАЗАТЬ ОТВЕТЫ
BEDmil00 BEDmil00  05.10.2020 19:18
Program ;
var
a: real;
begin
writeln('Введите сумму покупки.');readln(a);
if a > 100 thenwriteln('Предоставляется скидка 10%.')elsewriteln('Предоставлется скидка 5 %.');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика