Написать программу в pascal, которая вычисляет среднюю оценку за неделю (с массивов)

smartass2 smartass2    1   23.08.2019 07:30    5

Ответы
roma1234563 roma1234563  05.10.2020 14:06
//PascalABC.Net
begin
var a: array of integer;
setLength (a, readinteger('Введите кол-во учеников: '));
for var i:=0 to length(a)-1 do a[i]:=readinteger ('Введите оценку ученика: ');
write ('Средняя оценка: ', a.Average);
end.
ПОКАЗАТЬ ОТВЕТЫ
samirdebilGost samirdebilGost  05.10.2020 14:06
Program n1;
const n=12;
var a: array[1..n] of integer;
i,sum: integer;
begin
randomize;
sum:=0;
write('оценки за неделю: ');
for i:=1 to n do
begin
a[i]:=random(4)+2;
write(a[i],' ');
end;
writeln;
for i:=1 to n do sum:=sum+a[i];
writeln('среднее арифмитическое: ',sum/n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика