Написать программу в pascal, которая сортирует массив и находит количество различных чисел в нём

10ok 10ok    2   11.09.2019 11:00    0

Ответы
andreybober20 andreybober20  07.10.2020 07:20
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
  a.Sort; a.Println;
  Writeln('Кол-во разных чисел равно ',a.Distinct.Count)
end.

Пример
n= 13
-1 1 3 -2 8 -9 9 -1 -8 -8 9 -9 2
-9 -9 -8 -8 -2 -1 -1 1 2 3 8 9 9
Кол-во разных чисел равно 9
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика