Написать программу в pascal, используя массивы. дано массив а[1..n]. сделать программу которая выводит те элементы массива? индексы которых являются степени двойки желательно с обьяснением строк

Snezhana206 Snezhana206    3   08.06.2019 15:30    5

Ответы
djghjc13 djghjc13  01.10.2020 22:18
Const
  n = 100;

var
  a: array[1..n] of integer;
  i: integer;

begin
  //заполняем массив случайными значениями в диапазоне [0;100]
  Randomize; //инициализация датчика случайных чисел
  for i := 1 to n do a[i] := random(100);
  i := 1;  //1 - это два в нулевой степени
  while i < n do
  begin
    writeln('a(', i, ')=', a[i]);
    i := 2 * i;  //удваиваем индекс, чтобы получить очередную степень двойки
  end
end.

Результат работы программы:
a(1)=26
a(2)=21
a(4)=29
a(8)=74
a(16)=23
a(32)=44
a(64)=20
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика