Написать программу в pascal даны число a> 0, числа x1, необходимо вводить числа x1, , пока сумма модулей введенных чисел будет меньше a. определить число введенных чисел. p.s в поисковике искал, нашел 2 какие-то странные программы, они мне не подходят

Ника290305 Ника290305    1   26.09.2019 22:10    4

Ответы
katya100507 katya100507  11.08.2020 07:48
Var
  a,x,k,s:integer;
begin
  Write('a=');
  Readln(a);
  k:=0;
  s:=0;
  while s<a do
  begin
    Read(x);
    s:=s+abs(x);
    Inc(k)
  end;
  Writeln('Введено чисел ',k)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика