Написать программу в pascal числа a,b и c вводятся с клавиатуры.найти max(a,a+b)+max(a,b+c)/1+max(a+b*c,1,5)

Anuliks Anuliks    2   28.06.2019 16:50    0

Ответы
hessous hessous  22.07.2020 20:16
Уверен, что формула в условии написана неверно, но уж как написано...

var
  a,b,c:real;
begin
  Write('Введите a,b,c: '); Read(a,b,c);
  Writeln('Результат: ',max(a,a+b)+max(a,b+c)/1+max(max(a+b*c,1),5))
end.

Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 31

А вот так, на мой взгляд, должно быть:
var
  a,b,c:real;
begin
  Write('Введите a,b,c: '); Read(a,b,c);
  Writeln('Результат: ',(max(a,a+b)+max(a,b+c))/(1+max(a+b*c,1.5)))
end.

Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 0.6
ПОКАЗАТЬ ОТВЕТЫ
KKIUY KKIUY  22.07.2020 20:16
Function max (var first,second:real): real;
begin 
if first > second then max:=first else max:= second;
end;

var a,b,c,y : real;
begin 
writeln('Ведите a,b,c через пробел и нажмите Enter: '); 
 read(a,b,c); 
y:= max(a,a+b)+max(a,b+c)/1+max(a+b*c,1.5); 
 writeln('ответ: ',y);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика