Написать программу в pascal abc для вычисления среднего гармонического значения элементов массива х (n), кратных двум. при этом даны ограничения, что xi> 0, n< 30. n должно выбираться через генератор случайных чисел random и randomize.

VTKOF VTKOF    1   31.07.2019 11:30    6

Ответы
Var
    a: array[1..100] of integer;
    i, n: integer;
    harmonic: real;
    k: integer;

begin
    Randomize;
    n := random(20) + 10;
    
    for i := 1 to n do
    begin
        a[i] := random(50);
        write(a[i], ' ');
    end;
    writeln();
    
    harmonic := 1;
    k := 0;
    for i := 1 to n do
    begin
        if a[i] mod 2 = 0 then {фильтр}
        begin
            harmonic := harmonic + 1 / a[i];
            k := k + 1;
        end;
    end;
    writeln('harmonic mean = ', k / harmonic);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика