Написать программу в которой замена производится по такому правилу: если число делится на 2, то оно умножается на 4. если нет - к нему прибавляется 1. p.s. на паскале. , ! я в информатике полный ноль.

KarinaMalfoy08 KarinaMalfoy08    3   09.09.2019 15:40    2

Ответы
Hi12349 Hi12349  07.10.2020 03:33

//PascalABC.Net v3.1

var n:integer;

begin

  readln(n);

  if n mod 2 = 0 then n:=n*4 else n:=n+1;

  writeln(n);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика