Написать программу, в которой вводится последовательность целых чисел, оканчивающаяся нулем (т.е. признак окончания ввода чисел в последовательности – ввод нуля). программа должна посчитать и вывести количество отрицательных чисел в этой последовательности. программу реализовать двумя при цикла с пред- и пост- условием.

karinatrunko karinatrunko    1   12.08.2019 02:40    1

Ответы
Pashitsyna Pashitsyna  08.09.2020 12:58
Var
    number: integer;
    k: integer;

begin
    repeat
        write('number = ');
        readln(number);
        
        if number < 0 then k := k + 1;
    until number = 0;
    
    writeln('Кол-во отрицательных = ', k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика