Написать программу в которой определяется сумма s всех целых чисел в интервале, заданном переменными n и m, а так же сумма sa четных и sb нечетных чисел в том же интервале, на языке pascal

tanyabober tanyabober    1   06.12.2019 09:48    13

Ответы
Ihop Ihop  10.10.2020 18:51

var i,n,m,s,sa,sb: integer;

begin

write('n = ');

readln (n);

write('m = ');

readln (m);

for i:=n to m do

begin

s:=s+i;

if i mod 2 = 0 then sa:=sa+i else sb:=sb+i

end;

write('s = ',s,' sa = ',sa,' sb = ',sb)

end.

Объяснение:

Если интервал [n,m]

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика