Написать программу в free pascal: дано целое число неизвестной размерности. найти сумму цифр его составляющих.

Инав Инав    1   23.05.2019 12:00    2

Ответы
Braīŋľÿ Braīŋľÿ  01.10.2020 09:53
Var n,sum:integer;
begin
  sum:=0;
  write ('N = ');
  readln (n);
  while n <> 0 do
    begin
      sum:=sum+n mod 10;
      n:=n div 10;
    end;
  writeln ('Summa: ',sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика