Написать программу в формате "паскаль", которая генерируется случайное трехзначное число и подсчитает количество цифр в нем равных 4 и 5. ! , !

яна1764 яна1764    3   23.08.2019 15:40    4

Ответы
redvellk7 redvellk7  05.10.2020 14:52
// PascalABC.NET 3.2, сборка 1387 от 17.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  randomize;
  var s:=Random(100,999).ToString;
  Writeln('Исходное число ',s);
  var k4:=0;
  var k5:=0;
  for var i:=1 to s.Length do
  case s[i] of
  '4':k4+=1;
  '5':k5+=1
  end;
  Writeln('Четверок в числе- ',k4,', пятерок- ',k5)
end.

Пример
Исходное число 954
Четверок в числе- 1, пятерок- 1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика