Написать программу в delphi 7, содержащую цикл для вычисления функции если n=10, a0=0.75, a1=1.6, a2=a3==a10=2.0; x изменяется с шагом h=0.2 от x1=0 дo x2=2.0.

sallga sallga    1   26.05.2019 09:20    3

Ответы
uefip uefip  01.10.2020 12:00
Const
  a: array[1..11] of real = (0.75, 1.6, 2, 2, 2, 2, 2, 2, 2, 2, 2);

var
  x, h, x1, x2: real;

function F(x: real): real;
var
  i: integer;
  x_n, res : real;
begin
  res := a[1];
  x_n := 1;
  for i := 1 to 10 do
  begin
    x_n := x_n * x;
    res := res + a[i + 1] * x_n;
  end;
  F := res;
end;

begin
  x1 := 0; x2 := 2;
  h := 0.2;
  x := x1;
  repeat
    writeln('x = ', x:3:1, '  y = ', F(x):9:3);
    x := x + h;
  until x > x2;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика