Написать программу: треугольник задан длинами сторон a,b,c.определите вид треугольника(тупоугольный,прямоугольный,остроугольный)

МагистрЕдаа МагистрЕдаа    2   02.06.2019 01:20    3

Ответы
yanasmailik yanasmailik  02.07.2020 22:59
Var a,b,c:real;
begin
writeln ('Введите стороны треугольника');
read (a,b,c);
if ((a + b) > c) and ((a + c) > b) and ((b + c) > a) then
begin
if (sqr(a)+sqr(b)=sqr(c)) then writeln ('Это прямоугольный треугольник');
if (sqr(a)+sqr(b)>sqr(c)) then writeln ('Это остроугольный треугольник');
if (sqr(a)+sqr(b)<sqr(c)) then writeln ('Это тупоугольный треугольник');
end
else writeln ('Такого треугольника не существует');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика