Написать программу, суммирующую положительные элементы массива, полученную сумму возвести в квадрат (сделать через pascal)( надо ни то 2 поставят)

aidosashimbek200 aidosashimbek200    1   07.06.2019 22:10    5

Ответы
za2ba2wa2 za2ba2wa2  07.07.2020 12:06
Const  n = 10;  var  a :array [1..n] of integer;  i, sum :integer;
begin
  for i:= 1 to n do    readln(a[i]);    sum:= 0;  for i:= 1 to n do    if a[i] > 0 then      sum:= sum + a[i];  sum:= sqr(sum);  writeln(sum);      end.
ПОКАЗАТЬ ОТВЕТЫ
polinavak05 polinavak05  07.07.2020 12:06
Const N = 10;
Var i,S:integer; m:array [1..N] of integer;
Begin       
Writeln('Введите массив');       
for i:=1 to 10 do begin       
readln(m[i]);       
if m[i]>0 then S:=S+m[i]; end;       
S:=sqr(S);       
writeln('Сумма^2 равна ',S);       
readln;       
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика