Написать программу суммирования элементов массива, состоящего из 20 произвольных чисел до первого отрицательного числа. плз .

1232960 1232960    1   31.07.2019 20:00    4

Ответы
матвей462 матвей462  03.10.2020 18:57
Const n=20;
var a:array [1..n] of integer; 
s,i:integer; 
begin 
Randomize;
for i:= 1 to n do
 begin
 a[i]:=Random(21)-10;
 Write(a[i],' ')
 end;
writeln;
s:=0;
i:=1;
while (i<=n)and(a[i]>0) do 
 begin s:=s+a[i]; i:=i+1; end;
Writeln('Сумма элементов массива до первого отрицательного числа = ',s);
end.

Пример:
7 4 -5 6 -3 0 4 4 4 3 0 0 5 6 9 6 3 -9 -3 6 
Сумма элементов массива до первого отрицательного числа = 11
ПОКАЗАТЬ ОТВЕТЫ
Motornerplay Motornerplay  03.10.2020 18:57
Program symm;uses crt;
const N=20;
var masiv:array [1..20] of integer; i:integer; summa,x:integer;begin for i:= 1 to N do   begin    masiv[i]:=Random(25)-10;    Writeln(masiv[i])   end;  for i:= 1 to N do    if (masiv[i]>0) then    begin     x:=masiv[i];     summa:=summa+x;    end    else         begin    Writeln();     Writeln('Сумма элементов массива до первого отрицательного числа=',summa);     Halt    end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика