Написать программу, составить алгоритм заполнения массива десятью случайными целыми числами, каждое их которых лежит в пределах до 200. найти максимальное и минимальное из этих чисел, а также позиции, в которых они расположены. массив вывести на экран. заранее !

missvarvara2004 missvarvara2004    1   22.05.2019 08:10    4

Ответы
makcim2504 makcim2504  17.06.2020 12:12

clrscr;
randomize;
for i:=1 to 10 do
begin
a[i]:=random(201);
write(a[i],' ');
end;
max:=a[1]; min:=a[1];
for i:=1 to 10 do
begin
if a[i]>max then
begin
max:=a[i]; m:=i;
end;
if a[i]<min then
begin
min:=a[i]; n:=i;
end;
end;
writeln;
writeln('max=',max,'(nomer ',m,');');
writeln('min=',min,'(nomer ',n,');');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика