Написать программу сортировки массива по возрастанию из 10 случайных элементов. паскаль

rega1122 rega1122    3   24.09.2019 18:20    4

Ответы
шиканова шиканова  04.08.2020 15:25
Var a: array[0..9] of Integer;
i,k,b,c: Integer;
begin
for i:=0 to 9 do
begin
a[i]:=Random(100);
writeln(i+1,' число: ',a[i]);
end;
for i:=0 to 9 do
begin
for k:=0 to 9 do
begin
if a[i]<a[k] then
begin
b:=a[i];
c:=a[k];
a[i]:=c;
a[k]:=b;
k:=0;
end;
end;
end;
writeln('Числа по возрастанию:');
for i:=0 to 9 do
writeln(i+1,' число: ',a[i]);
begin
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика